Highlighted
Contributor - Level 2

Does G-System's EQ harm your signal quality when off?

As a real boost does not exist on the digital world, I learned that the best way to take advantage of G-System's tone clarity and signal-to-noise ratio is to turn the boost off.

Now I ask, Wouldn't the same principle apply to the EQ?

How does a digital EQ work?

Should I turn off my EQ and lock it?

Your experiences are much appreciated..
Guitars: Suhr Modern, Tom Anderson Classic, Fender Custom Shop 60's Strat Amps: Fargen Dual British, Marshall JMP 20 Fx: T Rex Moller > G-System: Xotic BB, Option 5 Destination Overdrive
Tags (1)
Sherwood Contributor - Level 2 2008-09-26

2008-09-26

Does G-System's EQ harm your signal quality when off?

As a real boost does not exist on the digital world, I learned that the best way to take advantage of G-System's tone clarity and signal-to-noise ratio is to turn the boost off.

Now I ask, Wouldn't the same principle apply to the EQ?

How does a digital EQ work?

Should I turn off my EQ and lock it?

Your experiences are much appreciated..

  • 0 Kudos
  • 10 Replies
  • Reply
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

Sherwood wrote:
As a real boost does not exist on the digital world, I learned that the best way to take advantage of G-System's tone clarity and signal-to-noise ratio is to turn the boost off.

Now I ask, Wouldn't the same principle apply to the EQ?

How does a digital EQ work?

Should I turn off my EQ and lock it?

Your experiences are much appreciated..

EQ is all about relative levels. A real EQ DOES exist in the digital world. If you don't use the on-board EQ, then by all means bypass it and lock it. If you always set it to the same settings, then get those settings where you want them and lock it. But otherwise...
Gtrs: PRS Cust. 24 20-Anny Artist, Yamaha PAC1511 Mike Stern Signature Pedalboard: Barber Tone Press, TC NovaDrive, TC G-System, Eventide ModFactor Rack: Egnater M4 Modular Tube Preamp, Randall RT2/50 Power Amp, Palmer ADIG-LB load box/cab sim Acoustic: Stehr Coco/Adi Custom-build OO, Stehr Koa/Adi Custom Build GA, Stehr Braz/Adi Custom Build GA, Taylor 814ce-L10, G-Natural
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

I'm thinking about using the eq as my boost. I'm setting it to boost mids and hi mids for solos. Works great at home-levels... I don't know how it's going to behave at full volume.

What u think?

I'll put this concept to test next wed with my band and will post the results here.

I'm still new to the G and experimenting with possibilities. Thanks!
Guitars: Suhr Modern, Tom Anderson Classic, Fender Custom Shop 60's Strat Amps: Fargen Dual British, Marshall JMP 20 Fx: T Rex Moller > G-System: Xotic BB, Option 5 Destination Overdrive
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

i think that is a great idea
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

How do you turn the eq off though?? I have read through the intruction but as soon as i turn it off in the menu its back on when i revisit. I have turned eq lock off but i cannot get the eq to stay off in a preset so i can lock it. I have the same problem with the boost.
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

shredtheater wrote:
How do you turn the eq off though?? I have read through the intruction but as soon as i turn it off in the menu its back on when i revisit. I have turned eq lock off but i cannot get the eq to stay off in a preset so i can lock it. I have the same problem with the boost.

We need to check this - but I think the bug is actually in the menus.

When you turn the EQ off and save you patch - it IS off.
But if you go into the EQ section of the menus it gets turned on for some reason - no matter what.
Gtrs: PRS Cust. 24 20-Anny Artist, Yamaha PAC1511 Mike Stern Signature Pedalboard: Barber Tone Press, TC NovaDrive, TC G-System, Eventide ModFactor Rack: Egnater M4 Modular Tube Preamp, Randall RT2/50 Power Amp, Palmer ADIG-LB load box/cab sim Acoustic: Stehr Coco/Adi Custom-build OO, Stehr Koa/Adi Custom Build GA, Stehr Braz/Adi Custom Build GA, Taylor 814ce-L10, G-Natural
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

The same thing happens in the Boost menu on my G. It automatically turns on if you scroll to the boost menu or hit the boost button in edit mode.
Evil Robot C 30 and Bluesman 40 Watt in Stereo G System, Shur Roit, BB Preamp, Nova Drive, OCD V.4, 1990 Les Paul Custom HCS, 1980 Les Paul Custom Tobbacco Burst, Gretch 5120, Texas Telecaster, Strat Deluxe HSS, 57 Reissue Strat etc. etc. etc.
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

Yep, same thing with me. I don't think it's a failure... looks like it has been programmed this way.

But if you turn the eq off and save the preset it'll be off. At least with my G-System..
Guitars: Suhr Modern, Tom Anderson Classic, Fender Custom Shop 60's Strat Amps: Fargen Dual British, Marshall JMP 20 Fx: T Rex Moller > G-System: Xotic BB, Option 5 Destination Overdrive
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

Sherwood wrote:
I'm thinking about using the eq as my boost. I'm setting it to boost mids and hi mids for solos. Works great at home-levels... I don't know how it's going to behave at full volume.

What u think?

I'll put this concept to test next wed with my band and will post the results here.

I'm still new to the G and experimenting with possibilities. Thanks!

That is what I am doing when I need just a little boost, works great!!
Eganter M4 w/COD,EG5, (Pete moded)Super V & XTC, Randall RM4 w/ (Pete moded) XTC, Mr Scary, Blackface & Brown, TC G-system, Mesa Boogie Simul 395 stereo Tube Power Amp, Marshall 1965a&b 4x10 cabinets.
Highlighted
Contributor - Level 2

Re: Does G-System's EQ harm your signal quality when off?

same thing happens with the noise gate on my G...........

everytime i revisit after switching off, it's back on again........

switch off in a patch & save it works fine, guess the bug in the menu affects a few things........