Davidkiim Contributor - Level 2 2019-09-09

2019-09-09

X32’s remote ethernet jack not working

Hello!

I recently tried to connect my X32 to the wireless router and realized that the router is not “seeing” the mixer. By not “seeing” the mixer, I mean that when I look in the router page (by logging into the router website) it shows all other connected devices except the X32. I tried everything I found in forums with no luck at all. I also noticed that one of the yellow/orange(?) lights that indicates ethernet cable connection is on even when I don’t have a cable connected to it. The only thing I can think of is that the ethernet jack no longer works. Has anyone seen this problem before? If so, how can I fix this? If it’s broken, is it even fixable (by non professionals)? Sorry for the long post and thanks in advance!

  • 0 Kudos
  • 10 Replies
  • Reply
Highlighted
Contributor - Level 2

Re: X32’s remote ethernet jack not working

Got it. I’ll be able to check that on the weekend. Thank you so much for your help!! Let’s hope it’s a simple fix