Highlighted
Contributor - Level 2

XR18 and Macbook Pro AND Landingzone dock...

Okay, well, first of, hello community!  First time here.

So, Here is the situation.  I have an XR18, a macbook pro (mid2012) and just got a Landingzone Dock.

So I have had no issues connecting the XR18 to the macbook pro via ethernet and thunderbolt dongle.  No issues connecting to the XR18 from wifi.  I recently just got the landingzone dock for the macbook to clean up the desk situation.  It looks great and seems to be working. Sort of...

So, I tried connecting the XR18 to the landingzone ethernet port.  I have downloaded their drivers and such for the Gigabit 3.0 ethernet port.  According to the Macbook pro, the XR18 is connected.  I get same response as I do when connected through thunderbolt ethernet.  Says the same thing "hey!  Your connected! but you have no internet!"  Yeah, noted..great, so on apple thunderbolt ethernet, when you open up Xair edit and setup, it sees the mixer and connects.  When the ethernet is hooked straight into dock ethernet port, mac says its good to go, but Xair doesn't see anything...at all.  Sits there like a dumbsh*# with his mouth wide open catching flies.  I don't get it.  If the mac sees the XR18 then why the hell won't the software see it? 

Any ideas are greatly appreciated.  It's not a major issue since I can use the dongle into the dock's thunderbolt with no issues, it's just, it bugs me a little that what I want to do, i should be able to and I can't...

In those immortal words of Leeloo Dallas,  Plaise Haalp...

mutant33 Contributor - Level 2 2020-05-16

2020-05-16

XR18 and Macbook Pro AND Landingzone dock...

Okay, well, first of, hello community!  First time here.

So, Here is the situation.  I have an XR18, a macbook pro (mid2012) and just got a Landingzone Dock.

So I have had no issues connecting the XR18 to the macbook pro via ethernet and thunderbolt dongle.  No issues connecting to the XR18 from wifi.  I recently just got the landingzone dock for the macbook to clean up the desk situation.  It looks great and seems to be working. Sort of...

So, I tried connecting the XR18 to the landingzone ethernet port.  I have downloaded their drivers and such for the Gigabit 3.0 ethernet port.  According to the Macbook pro, the XR18 is connected.  I get same response as I do when connected through thunderbolt ethernet.  Says the same thing "hey!  Your connected! but you have no internet!"  Yeah, noted..great, so on apple thunderbolt ethernet, when you open up Xair edit and setup, it sees the mixer and connects.  When the ethernet is hooked straight into dock ethernet port, mac says its good to go, but Xair doesn't see anything...at all.  Sits there like a dumbsh*# with his mouth wide open catching flies.  I don't get it.  If the mac sees the XR18 then why the hell won't the software see it? 

Any ideas are greatly appreciated.  It's not a major issue since I can use the dongle into the dock's thunderbolt with no issues, it's just, it bugs me a little that what I want to do, i should be able to and I can't...

In those immortal words of Leeloo Dallas,  Plaise Haalp...

  • 0 Kudos
  • 5 Replies
  • Reply

Accepted Solutions
Highlighted
Contributor - Level 2

Re: XR18 and Macbook Pro AND Landingzone dock...

GOT IT!!!!  FIGURED IT OUT! 

I'm a bit of a dummy here but this will serve others....

INTERNET SHARING has to be turned off and re enabled with the Landing Zones ethernet port added to the list.

It was in the list when I went back to look at internet sharing, but the LandingZone Dock port was on list but not checked off.  Disabled Internet Sharing, checked the box for the new port, then re enabled sharing.

Ka BLAMO!  Works like a champ....whew!!

Gary, Thank you for your attempt to help!   It was because I went back and fiddled with the settings you talked about, and admittedly I didn't understand, that I went back and looked at internet sharing for a second.  So in a way, you did help!  Thanks!!

View solution in original post

Highlighted
Superhero - Level 1

Re: XR18 and Macbook Pro AND Landingzone dock...

@mutant33 

Hey, what settings are being used for XR18 lan? Is it set static or dhcp or dhcp server.

Thanks for the Accepted Solutions and Kudos! Always appreciated IF duly earned.
Highlighted
Contributor - Level 2

Re: XR18 and Macbook Pro AND Landingzone dock...

Set to DHCP.  I tried all three ways, won't recognize it at all.  Through apple thunderbolt ethernet dongle I have it set up through DHCP and seems to do it automatically.  So I thought it should be the same for the dock, but as a DHCP it doesn't come up.  Even though the xair application has an IP address that it got through the mac...

Highlighted
Superhero - Level 1

Re: XR18 and Macbook Pro AND Landingzone dock...

@mutant33 

What base ip does the dock use...or doesn't it? Maybe try a static ip for the xr within that range if it does. You could also try using a static ip for the computer, (ipv4 settings) I have had luck doing that with stubborn iPads.

Thanks for the Accepted Solutions and Kudos! Always appreciated IF duly earned.
Highlighted
Contributor - Level 2

Re: XR18 and Macbook Pro AND Landingzone dock...

Gary,    HAHAHAHAAHA   Like I know what you are actually talking about....LOL  okay serious now..

IP for the dock?  Dunno if it has one.  I haven't thought to try static IP.  I'll try to give that a shot but I'm still a proverbial n00b when it comes to IPv6 IPv4 all that. I'll see if I can look up how to do it and get back to you on that.

Highlighted
Contributor - Level 2

Re: XR18 and Macbook Pro AND Landingzone dock...

GOT IT!!!!  FIGURED IT OUT! 

I'm a bit of a dummy here but this will serve others....

INTERNET SHARING has to be turned off and re enabled with the Landing Zones ethernet port added to the list.

It was in the list when I went back to look at internet sharing, but the LandingZone Dock port was on list but not checked off.  Disabled Internet Sharing, checked the box for the new port, then re enabled sharing.

Ka BLAMO!  Works like a champ....whew!!

Gary, Thank you for your attempt to help!   It was because I went back and fiddled with the settings you talked about, and admittedly I didn't understand, that I went back and looked at internet sharing for a second.  So in a way, you did help!  Thanks!!

View solution in original post