This page is dedicated to the art of mixing. Join other producers and recording engineers and discuss mixing techniques, your favorite software, equipment and more!


No Luck Getting Network Configured With New XR12

Contributor - Level 2
Folks, I'm brand new here at the forums and I joined because I just bought an XR12. It arrived yesterday. I've been trying to get my XR12 synched to my computer for almost an entire day now, and I'm not having any luck. The computer is my DAW, a quad-core AMD Athlon machine, running 8 GB of ram. The OS is Win7.

First I tried following the instructions in the Quick Start Guide, which came with the mixer. Then i downloaded and printed out the X-Air User Manual. I'm trying to follow the instructions there but they don't always match my setup.

First I wanted to try using the XR12's wireless capability, so I installed a wireless adapter in my machine and set it up so it will be on its own network, which I named "Behringer XR12" (without the quotes, of course). Configured it as WPA2, set up a password, yadee, yadee. Then I set the XR12's network switch to WIFI Client. Booted the X-Air mixer, clicked on setup, and there was nothing showing. So I clicked on WLAN, set the securing, SSID, and KEY to match what I'd just configured my new PC network with. Selected DHCP, then clicked on APPLY. So I went over to Connection and had a look. I noticed that of all the menu buttons present, only the Initialize, Manual IP and Rescan buttons were highlighted. So I tried Rescan first. I was hoping to see the mixer name in the "Select Mixer from list" list, but nope, nothing down there. So I clicked on Rescan. Nothing. Well, I note that Rescan briefly turned a reddish hue and then I noticed that under Connection, there's a "Status:" description and across from it is a message, in cyan, reading "searching devices." I tried the Initialize button, in both sync directions, and this didn't make any difference.

So, I decided that, since I wasn't getting anywhere using the WLAN on my PC, maybe a direct network hookup would work. I didn't want to run my XR12 through my home router, which provides internet access via a cable to the DAW, and wireless access to a Windows laptop, an iPad, an iPod, and a couple of Android phones when they're around. So I installed another network card in my DAW, insured that it was working properly, then hooked the XR12 up directly to my DAW using a network cable. I set the XR12's switch to Ethernet . And then in the X-Air software's setup, I clicked on LAN. Now, since there is no router in this mix -- just a PC and the XR12, in the LAN mode setting, I selected DHCP Server. CLicked on APPLY, went back to Connection and still did not see the XR 12 in the list. So I clicked on Rescan, but it didn't make any difference. All the while, that "searching devices" note under "Status:" has remained lit. Well, since DHCP Server wasn't doing anything for me, next I tried just plain DHCP. Same difference, that is, no difference.

And then I notice that, under "This Computer" in the Setup window, it has some IP Addresses listed, to wit: and Now, I'm pretty sure that latter address is the same address the DAW has on my home network, but I haven't a clue where that first address is coming from. The documentation states that, when using X Air Edit for Windows that, after one clicks on Setup, the name of the XR device should appear as well as an address of Well, this clearly isn't happening. At all.

So next, I go to the Android Play Store and d/l a copy of X-Air for my Android phone. It installs fine and when I boot it, it comes up at least showing Wifi lock is set to "None." And when I click on that value, I see that I can toggle between "None" and the name of my home wifi network. I decide that I don't want to connect to my home wifi network, so I click on the wifi icon in my phone, which turns it off. So then I go back to the X-Air opening screen and I click on Connect. At first I'm getting a little message that says Wifi disconnected, and then suddenly "Wifi connected to [home network]." So even from within the X-Air app, it appears I'm stuck using my home wifi network. But while all this is going on, in big letters, it's saying Searching... it is stuck there. I let it sit there for a good 10 minutes and nothing happened. So, since X-Air wants to use my home wifi network, I figure I may as well set it up to use it right away. So instead of None, I indicate my home wifi network, and hit connect. And sit there for minutes staring at Searching . . .

Okay, I haven't gone upstairs and untangled the iPad from my wife's stuff yet, but I will. However, I'm willing to lay money at this point that using the iPad won't make a difference.

The only thing I haven't tried that might just possibly make a difference will be to run a network cable over to the router for the home network. Oh, and the iPad too, I suppose.

I've tried to follow the instructions in the Behringer docs as closely as I could, but it doesn't help matters when they're giving instructions and showing screen shots for versions that no longer correspond to what I just downloaded. This is a general pet peeve of mine that I run into very often when it comes to documenting how to get something done. In fact, I'm usually surprised when the documentation accurately describes how something is done, it's so uncommon.

Well, this post was a bit more long-winded than I would have preferred, but I wanted to describe as accurately and completely as possible what's going on here, so that hopefully you can spot any glaring oversight I may have committed. Cuz I really really don't want to have to return it due to faulty componetry. Which, to be perfectly honest, is what I think I've got on my hands right now. Another example of Chinese electronics that is defective right out of the box. I can't tell you how often this has occurred to me ever since electronics manufacture in China has become the default condition.
Michael My Music at Soundcloud: https://soundcloud.com/michaelmcbroom/albums

Re: No Luck Getting Network Configured With New XR12

Volunteer Moderator
Hi Michael,

Welcome to the forum. Sorry that you have been having problems connecting to your new XR12. I do not believe that it is the case of a defective unit, since in your descriptions, I can see a number of issues and misunderstanding on how networks and wifi works.

Since you have a home network, the easiest way to connect to the XR12 is to set the switch to LAN (far left) and connect the XR2 to your network using an ethernet cable (straight, not crossover), then turn it on. Your network router will assign an IP address to the XR12 using the same subnet as the rest of your network. This is the way I connect (XR18, MR18, MR12 or X32 Racks) when not out doing an event.

Once that is done, run the X-Air Edit and select Setup. On the Connection screen, the XR12 should show up in the list. Select it and click on the Connect button.

If you do want to try out the built in wireless, change the switch on the XR12 to Access Point and turn it on. Then go to the WIFI listing in Windows (on the taskbar) and select the XR12 and connect. Once connected, run the X-Air Edit and you should see the XR12 in the Connection list.
Paul Vannatto, Volunteer Forum Administrator and Moderator

Re: No Luck Getting Network Configured With New XR12

Contributor - Level 2
Hey Paul,

Thanks for the reply. Well, you pointed out the two things I'd been dragging myself over trying. I'll need to buy a longer network cable to reach my router and I just didn't want to mess with turning the XR12 into an access point. But I'm gonna be driving right by a Best Buy, so I'll drop in there and pick up a longer cable. Maybe I'll try the Access Point thing later.

Oh and just to add to the above note of mine, I did try to get things linked up with my iPad last night. I followed the directions that were given by a Behringer guy --- just went to the Wifi section of the iPad so I could pick out the XR12 from the list of Wifi stations in my neighborhood. But the XR12 was nowhere to be found, and yes, I had it set to Wifi Client, the middle selection. So no joy on that one either. I sure hope this thing is ok and I'm still doing something wrong. But that Behringer guy's directions were dead simple to follow, but still no joy.

Even though I didn't add an address into the X-Air's setup screen, do you think maybe I need to reset it with a paper clip again?
Michael My Music at Soundcloud: https://soundcloud.com/michaelmcbroom/albums

Re: No Luck Getting Network Configured With New XR12

Contributor - Level 2
If you want to connect your iPad directly to the XR12 you need to set the XR to the Wireless Access Point mode with it's switch fully to the right. Then your iPad should be able to find the XR12 as it's own WiFi signal and allow you to connect direct without going anywhere near your home WiFi router. Smiley Happy It should then find the XR address in the 192:168:1x range.

Re: No Luck Getting Network Configured With New XR12

Contributor - Level 2
Thanks for the clarification, Richard. I'll give this a try too.

Hm, given that I installed a USB Wifi dongle thingie in my DAW, I'm guessing it might be able to pick up the XR12 as well in this mode? That would be nice. I think I'm gonna try this first; that way I don't have to mess with a network cable.
Michael My Music at Soundcloud: https://soundcloud.com/michaelmcbroom/albums

Re: No Luck Getting Network Configured With New XR12

Contributor - Level 2
Yay! We have joy!

Setting the XR12 up as an access point worked. It took a moment for me to realize that I had to go into my PC's network settings and look for the XR 12 among the Wifi sources. Yep, there it was. All the rest was pretty easy to figure out.
Michael My Music at Soundcloud: https://soundcloud.com/michaelmcbroom/albums

Re: No Luck Getting Network Configured With New XR12

Contributor - Level 2
Smiley Very Happy
Conversation Stats
  • 6
  • Replies
  • 140
  • Views
  • 0
  • Kudos Given
  • 3
  • Contributors