Highlighted
Contributor - Level 2

X32 Edit version 4.1 on Mac does not work

Hi 

Yesterday Dec 9th. it was released a new version 4.1 of X32 Edit. I downloaded it today on macOS Catalina 10.15.1 to try it out. But it will not start at all on my computer. Luckily, its possible to download legacy versions so redownloaded and I tried the version 3.2 and there is no such problems. So, something is wrong with 4.1. The message I get is only:

The application “X32-Edit” can’t be opened.

runesig Contributor - Level 2 2019-12-09

2019-12-09

X32 Edit version 4.1 on Mac does not work

Hi 

Yesterday Dec 9th. it was released a new version 4.1 of X32 Edit. I downloaded it today on macOS Catalina 10.15.1 to try it out. But it will not start at all on my computer. Luckily, its possible to download legacy versions so redownloaded and I tried the version 3.2 and there is no such problems. So, something is wrong with 4.1. The message I get is only:

The application “X32-Edit” can’t be opened.


Accepted Solutions
Highlighted
Contributor - Level 2

Re: X32 Edit version 4.1 on Mac does not work

It works just fine, change your security setting that is the problem, not the app

Owner of small gospelfacility service in the Netherlands. X32 console two racks of S16 and 6 P16

View solution in original post

Highlighted
Contributor - Level 2

Re: X32 Edit version 4.1 on Mac does not work

It works just fine, change your security setting that is the problem, not the app

Owner of small gospelfacility service in the Netherlands. X32 console two racks of S16 and 6 P16

View solution in original post

Highlighted
Contributor - Level 2

Re: X32 Edit version 4.1 on Mac does not work

Thanks Walter, I got it to work by using these commands in Terminal:

cd /Applications
sudo chmod -R ug+x X32-Edit.app

A little strange that I had to to this to make it work but at least I am running version 4.1 on Catalina. 

Highlighted
Contributor - Level 2

Re: X32 Edit version 4.1 on Mac does not work

Hi all,

I've tried the Terminal commands recommended and X32-Edit V4.1 STILL will not work...

HELP!!!!

Highlighted
Contributor - Level 2

Re: X32 Edit version 4.1 on Mac does not work

My persistent Error Message....

Highlighted
Contributor - Level 2

Re: X32 Edit version 4.1 on Mac does not work

I think you have to go into "System Preferences" -> "Security & Privacy" and allow the app to open from there.

Highlighted
Super Contributor - Level 2

Re: X32 Edit version 4.1 on Mac does not work

Simple solution.

When you get that error message click on the "Show in Finder" button. This should open a Finder window with the application visible.

Control-click (right-click) on the application to get the contextual menu and choose "Open". You will be presented with a slightly different dialog box that gives you the option to open the application. Click on the "Open" button. This will allow the application to run, and it is remembered, so you should be good to go.

I just did this on 10.15.2 with no surprises. Now if I actually had an X32 here in the studio I use the application to set up live performances for some folks who occasionally run into a venue that has an X32 for them to use.

Logic Pro X 10.4.8, 10.5.0, X-Touch 1.15, XR18 1.5, macOS 10.14.5|10.15.2