Mixing

This page is dedicated to the art of mixing. Join other producers and recording engineers and discuss mixing techniques, your favorite software, equipment and more!

Highlighted

XR18 USB device not detected - Win10/64bit

Contributor - Level 2
Hi,

I'm having problems getting my XR18 to work over USB with Win10 64bit.
I've installed the driver v4.38, and at the end of the installation I get the message about 'disconnecting/re-connecting' the device to complete the installation.
The wording of this is confusing to me. Does it mean literally pull out the USB cable and plug it in again? Re-cycle power to the unit? I've tried each anyway but nothing.
I've gone over the manual and I'm not sure if the device should be connected or powered on or off while installing the drivers (I've tried both).

I've also got a Focusrite Saffire Pro 24 connected via firewire. Ideally I'd like to use this for Windows system audio and use my XR18 for audio work with my DAW (Cubase Elements).
If I have to I could just ditch the Saffire altogether if it's causing conflicts, though I'd rather not.

I've uninstalled the Saffire now and tried installing the XR18 driver again, but no luck.

Any suggestions?
3 REPLIES 3

Re: XR18 USB device not detected - Win10/64bit

Contributor - Level 2
OK I seem to have the drivers installed correctly, I've ditched the Focusrite for now so I've just got the XR18 connected via USB.
Right now I'm just trying to get some audio into one of the XR18 inputs and out of my main monitors, but I'm getting nothing.
In the top left corner of the X-Air Edit screen it says [Device: (Not Connected)] and I'm not getting any input signal showing in the meters of X-Air Edit.

I feel I'm missing some basic understanding of how this thing works.Smiley Sad

Re: XR18 USB device not detected - Win10/64bit

Volunteer Moderator
Hi James,

Welcome to the forum. The USB (and drivers) transfers the audio between the XR18 and the computer. The X-Air Edit is one of the control apps that connects to the XR18 via ethernet (or wifi). Have a look at this thread.
Paul Vannatto, Volunteer Forum Administrator and Moderator

Re: XR18 USB device not detected - Win10/64bit

Contributor - Level 2
Thanks Paul.

Yes, I realised this late last night. I had thought I only needed that functionality if I was using a remote device like a tablet. I'm so used to my old audio interface, I'm still getting used to this idea.

So I've been trying to connect to the XR18 through Wifi today, but I'm not seeing a Wifi logo anywhere in Win10. This seems to be a Win10 issue but I'm struggling to find a working solution.

I'm going to just trying connecting via ethernet, but I'm a bit concerned about the reference to 'unauthorized access' in the manual. I'm not sure I know how to disable that in my router, but I'll see how it goes.
Conversation Stats
  • 3
  • Replies
  • 136
  • Views
  • 0
  • Kudos Given
  • 2
  • Contributors