Highlighted
Contributor - Level 1

Alter Ego Vintage Echo x4 presets mess

Hello,
my pedal became a mess. All factory presets are replaced with the one I save last. There is no pattern. So if I switch A on, turn knob to TR ORGAN, it's ok, I press B, there is latest preset from latest save from anywhere. I press A again, there is no TR ORGAN anymore, but preset from somewhere else. I tried to "re-save" with press A, turn knob somewhere else, back to TR ORGAN (now the right sound is on), hold A, saved with green flashes OK, but guess what, now the TR ORGAN A is every where I turn knob with B->A press. So it's a totally mess. Pedal is 2 years old and I used it 3 times a week.

Can somebody help me please with some kind of reset? It's a 255€ device and I can't believe it died after two years... Smiley Sad
Tags (1)
gintrnis Contributor - Level 1 2019-02-03

2019-02-03

Alter Ego Vintage Echo x4 presets mess

Hello,
my pedal became a mess. All factory presets are replaced with the one I save last. There is no pattern. So if I switch A on, turn knob to TR ORGAN, it's ok, I press B, there is latest preset from latest save from anywhere. I press A again, there is no TR ORGAN anymore, but preset from somewhere else. I tried to "re-save" with press A, turn knob somewhere else, back to TR ORGAN (now the right sound is on), hold A, saved with green flashes OK, but guess what, now the TR ORGAN A is every where I turn knob with B->A press. So it's a totally mess. Pedal is 2 years old and I used it 3 times a week.

Can somebody help me please with some kind of reset? It's a 255€ device and I can't believe it died after two years... Smiley Sad

  • 0 Kudos
  • 0 Replies
  • Reply