Highlighted
Contributor - Level 2

ASIO for UMC404HD

Hello, regarding UMC404HD

The Windows 10 plug-and-play drivers gives me the option for DX and MME on my workstation. I downloaded the driver from your download page for the device and install, and it actually breaks the audio. I have to "remove devices" in device manager, and reboot to be able to use the interface again.

I'm trying to use ASIO drivers with my DAW so I can cut down on latency with a USB MIDI controller. please advise.

Many thanks!
- Eli
ElijahRockers Contributor - Level 2 11-29-2018

11-29-2018

ASIO for UMC404HD

Hello, regarding UMC404HD

The Windows 10 plug-and-play drivers gives me the option for DX and MME on my workstation. I downloaded the driver from your download page for the device and install, and it actually breaks the audio. I have to "remove devices" in device manager, and reboot to be able to use the interface again.

I'm trying to use ASIO drivers with my DAW so I can cut down on latency with a USB MIDI controller. please advise.

Many thanks!
- Eli

Valued Contributor - Level 1

Re: ASIO for UMC404HD

Elijah Rockers;156167 wrote:
Hello, regarding UMC404HD

The Windows 10 plug-and-play drivers gives me the option for DX and MME on my workstation. I downloaded the driver from your download page for the device and install, and it actually breaks the audio. I have to "remove devices" in device manager, and reboot to be able to use the interface again.

I'm trying to use ASIO drivers with my DAW so I can cut down on latency with a USB MIDI controller. please advise.

Many thanks!
- Eli

Hi Eli,

What version of drivers do you have loaded? Should be 4.38. What DAW are you using? You should select ASIO as the audio interface driver in your DAW.

Also, ASIO has nothing to do with USB MIDI so it will not help with MIDI controller lag. That sounds like a separate issue.

Ken
If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver