Contributor - Level 2

ASIO not active, XR18 audio not working in Cakewalk by Bandlab

Hello Behringer Experts,

I've searched the online forums and help documentation, and couldn't find a resolution so I am now contacting you. Thanks in advance for your help.

Equipment and software:

Behringer X-AIR USB driver v 4.59.0 (most current driver)
Behringer XR18 digital mixer firmware v 1.17 (most current firmware)
Cakewalk by Bandlab v 2019.07 (Build 79, 64 bit)
USB cable to Windows 10 64bit

I've used my Behringer XR18 digital mixer as an audio interface (via X-AIR ASIO) to Cakewalk for a several months without issue - it used to work great until today. For some reason just now, I am not able to get audio through the Behringer to Cakewalk even though the Driver mode is set to ASIO and all the Input Drivers from the XR18 ASIO driver as listed as normal. I also made sure that each track as the appropriate input driver selected per track.

I'm fairly certain the X-AIR Control Panel used to say ASIO Active when I have Cakewalk open. It now says ASIO not active, even when Cakewalk is open.

I've uninstalled and re-installed the Behringer driver, I've downgraded the driver, then re-updated the driver and have uninstalled and re-installed Cakewalk as well. No luck.

I've also made certain that my XR18 mixer's USB Sends are routed correctly in the X-Air Edit app. Nothing has changed in that regard.

Any ideas?

Thank you!

Tags (3)
russwbl Contributor - Level 2 2019-09-10

2019-09-10

ASIO not active, XR18 audio not working in Cakewalk by Bandlab

Hello Behringer Experts,

I've searched the online forums and help documentation, and couldn't find a resolution so I am now contacting you. Thanks in advance for your help.

Equipment and software:

Behringer X-AIR USB driver v 4.59.0 (most current driver)
Behringer XR18 digital mixer firmware v 1.17 (most current firmware)
Cakewalk by Bandlab v 2019.07 (Build 79, 64 bit)
USB cable to Windows 10 64bit

I've used my Behringer XR18 digital mixer as an audio interface (via X-AIR ASIO) to Cakewalk for a several months without issue - it used to work great until today. For some reason just now, I am not able to get audio through the Behringer to Cakewalk even though the Driver mode is set to ASIO and all the Input Drivers from the XR18 ASIO driver as listed as normal. I also made sure that each track as the appropriate input driver selected per track.

I'm fairly certain the X-AIR Control Panel used to say ASIO Active when I have Cakewalk open. It now says ASIO not active, even when Cakewalk is open.

I've uninstalled and re-installed the Behringer driver, I've downgraded the driver, then re-updated the driver and have uninstalled and re-installed Cakewalk as well. No luck.

I've also made certain that my XR18 mixer's USB Sends are routed correctly in the X-Air Edit app. Nothing has changed in that regard.

Any ideas?

Thank you!

  • 0 Kudos
  • 7 Replies
  • Reply

Accepted Solutions
Contributor - Level 2

Re: ASIO not active, XR18 audio not working in Cakewalk by Bandlab

Have you moved your USB cable to a different port on your computer? Also, have you tried a different USB cable? Does the Xair show up under playback and recording devices on your PC?  Also make sure your USB cable is connected securely in the Xair. 

Contributor - Level 2

Re: ASIO not active, XR18 audio not working in Cakewalk by Bandlab

Have you moved your USB cable to a different port on your computer? Also, have you tried a different USB cable? Does the Xair show up under playback and recording devices on your PC?  Also make sure your USB cable is connected securely in the Xair. 

Volunteer Moderator

Re: ASIO not active, XR18 audio not working in Cakewalk by Bandlab


@russwbl wrote:

I've used my Behringer XR18 digital mixer as an audio interface (via X-AIR ASIO) to Cakewalk for a several months without issue - it used to work great until today.


Did Win10 do an update by chance? It may have set the privacy setting for the mic off (which does affect the ASIO drivers). It seems to be a known issue of Win10 that they think they know better than the user. I'm still using Win7 and will stay there as long as I can. Check the privacy settings.

 

Paul Vannatto, Volunteer Forum Administrator and Moderator
Contributor - Level 2

Re: ASIO not active, XR18 audio not working in Cakewalk by Bandlab

@Paul_Vannatto , thanks for the advice.  I checked the privacy settings in Windows 10, but don't see anything related to microphones or audio, etc.  I am using a desktop PC with no webcam so maybe mic/audio options would be omitted in the privacy settings in my setup.

I did get this working.  I tried a different USB port, and that caused the ASIO to flip to ASIO Active in the X-Air Control Panel, but still no audio at the Cakewalk inputs.  I selected a different Driver Mode in Cakewalk (again... I had tried that previously), then reset it back to ASIO.  However, I still wasn't getting audio to meter on my Cakewalk input tracks.  However, as soon as I chose an output for my master bus, viola - fixed!  I could get audio to the input tracks.  My master bus previously did not have any output driver.  I have no idea why a blank/none output driver on the master bus would affect the input tracks, but it does.  If I set the master bus' output driver to "none", the input tracks do not get signal.  Strange.

Now, if I use the original USB port on my PC that previously would not work, I also works as it should as long as I specify an output driver on the master bus.  I don't understand why that would be a requirement, but it appears to be the case, at least for my setup/configuration.  Again, strange.

Contributor - Level 2

Re: ASIO not active, XR18 audio not working in Cakewalk by Bandlab

@AlIrwin after your post, I did the following (also replied the same info to another poster who had replied).  Essentially, your advice to try a different USB port seemed to be the catalyst to get me headed down the path to success, so many thanks to you!

I did get this working.  I tried a different USB port, and that caused the ASIO to flip to ASIO Active in the X-Air Control Panel, but still no audio at the Cakewalk inputs.  I selected a different Driver Mode in Cakewalk (again... I had tried that previously), then reset it back to ASIO.  However, I still wasn't getting audio to meter on my Cakewalk input tracks.  However, as soon as I chose an output for my master bus, viola - fixed!  I could get audio to the input tracks.  My master bus previously did not have any output driver.  I have no idea why a blank/none output driver on the master bus would affect the input tracks, but it does.  If I set the master bus' output driver to "none", the input tracks do not get signal.  Strange.

Now, if I use the original USB port on my PC that previously would not work, I also works as it should as long as I specify an output driver on the master bus.  I don't understand why that would be a requirement, but it appears to be the case, at least for my setup/configuration.  Again, strange.

Volunteer Moderator

Re: ASIO not active, XR18 audio not working in Cakewalk by Bandlab


@russwbl wrote:

Again, strange.


Welcome to the new world of Win10   Glad to hear that you got it working. 

 

Paul Vannatto, Volunteer Forum Administrator and Moderator
Contributor - Level 2

Re: ASIO not active, XR18 audio not working in Cakewalk by Bandlab

Thanks @Paul_Vannatto !  I'm thankful that this forum has active users such as yourself with helpful advice!

Volunteer Moderator

Re: ASIO not active, XR18 audio not working in Cakewalk by Bandlab


@russwbl wrote:

I'm thankful that this forum has active users such as yourself with helpful advice!


You are most welcome Russ. Hopefully in the future you will be able return the favour and help someone else out here on the forum.

Paul Vannatto, Volunteer Forum Administrator and Moderator