Highlighted
Contributor - Level 1

Can't get UMC22 to work

I just received my UMC22 audio interface, if I set it as the playback device I can hear the sound fine, but I'm having trouble with the input (using Windows 10).

I plugged it in and Windows showed a notification that the drivers were installed, and I can indeed see the device in both playback and recording device menus.

I tried to record something in Audacity, but it didn't pick up the input at all. I then set the UMC22 as the default recording device in Windows, and set it to 2 channels. Now the input seems to get picked up by Audacity, but it is very quiet, even with max gain on the audio interface. AIso, I can only hear audio through the right channel, but I don't know if that's unintended. The input does not get picked up at all when set it to 1 channel in Windows. Different kHZ values also do not change anything.

I also tried installing the ASIO drivers and set the audio interface as the default device in the ASIO control panel, and then tried using Amplitube. I set the audio driver to ASIO in Amplitube, but it again didn't work. I also tried some different Behringer drivers, and again selected the UMC ASIO drivers in Amplitube, but again it didn't work, asking me to connect an audio device.

I couldn't install the v2.23 Behringer driver at all, since it kept asking me to connect the device, even though it was connected and Windows seems to pick it up. The v3.29 driver installed, but again in the Behringer control panel it says that no audio devices are connected.

Lastly, when I use direct monitoring on the interface, I can hear everything completely fine, so I assume it's a software issue.

I hope that what I wrote makes sense, and I'd greatly appreciate any help!
DaveTumskis Contributor - Level 1 2018-07-10

2018-07-10

Can't get UMC22 to work

I just received my UMC22 audio interface, if I set it as the playback device I can hear the sound fine, but I'm having trouble with the input (using Windows 10).

I plugged it in and Windows showed a notification that the drivers were installed, and I can indeed see the device in both playback and recording device menus.

I tried to record something in Audacity, but it didn't pick up the input at all. I then set the UMC22 as the default recording device in Windows, and set it to 2 channels. Now the input seems to get picked up by Audacity, but it is very quiet, even with max gain on the audio interface. AIso, I can only hear audio through the right channel, but I don't know if that's unintended. The input does not get picked up at all when set it to 1 channel in Windows. Different kHZ values also do not change anything.

I also tried installing the ASIO drivers and set the audio interface as the default device in the ASIO control panel, and then tried using Amplitube. I set the audio driver to ASIO in Amplitube, but it again didn't work. I also tried some different Behringer drivers, and again selected the UMC ASIO drivers in Amplitube, but again it didn't work, asking me to connect an audio device.

I couldn't install the v2.23 Behringer driver at all, since it kept asking me to connect the device, even though it was connected and Windows seems to pick it up. The v3.29 driver installed, but again in the Behringer control panel it says that no audio devices are connected.

Lastly, when I use direct monitoring on the interface, I can hear everything completely fine, so I assume it's a software issue.

I hope that what I wrote makes sense, and I'd greatly appreciate any help!

  • 0 Kudos
  • 12 Replies
  • Reply
Highlighted
Triber Moderator

Re: Can't get UMC22 to work

Hi Dave, welcome to the forum!

Which Windows operating system are you using on your PC? Have you tried using a different computer to see if the same behavior occurs?
Michael Lapke
Highlighted
Contributor - Level 1

Re: Can't get UMC22 to work

Michael Lapke;148933 wrote:
Hi Dave, welcome to the forum!

Which Windows operating system are you using on your PC? Have you tried using a different computer to see if the same behavior occurs?


Using Windows 10 64-bit. I don't have another PC available so I can't test it.

I tried playing around in the ASIO control panel and I got it to work with Amplitube. I had to disable everything besides the audio interface itself in the advanced settings, and set the left and right channel inputs to the same values in Amplitube.

Audacity doesn't seem to support the ASIO drivers, so I guess I can't properly use the interface with such software?
Highlighted
Volunteer Moderator

Re: Can't get UMC22 to work

You can use audacity with asio but you need to perform some work yourself.

https://wiki.audacityteam.org/wiki/ASIO_Audio_Interface
Robert Lofgren | Did you find my post helpful? Give kudos and/or mark it as a solution!
Highlighted
Contributor - Level 2

Re: Can't get UMC22 to work

I think it was a recent update to Windows 10 that added or changed some 'privacy' settings for a few devices, one being the microphone. I believe an interface is considered a 'microphone' and by default it may be disabled which not allow it to pick up and record sounds.
The Microsoft link below explains it and how to enable the microphone for an app/program. I'm still on a Win 7 PC, so I haven't encountered this, but just what I seen from a few other users with similar Win 10 issues.
https://privacy.microsoft.com/en-us/windows-10-camera-and-privacy
Highlighted
Contributor - Level 1

Re: Can't get UMC22 to work

Hi All,

I too cant get my UMC22 to work, although I cant even get the SIG lights to flash when plugging in an instrument.
I've tried both ASIO & Behringer drivers and still no good.

It seems that even if I install the ASIO drivers when I connect the UMC22 windows automatically downloads Behringer drivers for it.
I've tried updating the drivers by selecting the ASIO folder but it says there are no driver files compatible.

What's worse is I had it working a day ago.

Ive tried everything & Im simply stuck, not sure what to do next - Any help would be greatly appreciated!!
Highlighted
Triber Moderator

Re: Can't get UMC22 to work

Hi Brett,

Welcome to the forum! Your issue could stem from a few different thing, but we might need more information to help you with troubleshooting.

Brett Boustead;149348 wrote:

I too cant get my UMC22 to work, although I cant even get the SIG lights to flash when plugging in an instrument.
I've tried both ASIO & Behringer drivers and still no good.


If you aren't getting a signal light when plugging in an instrument to the UMC22 then that sounds more like you haven't properly set the instrument output volume or UMC22 input gain for the channel you're plugging into. That has nothing to do with which driver you are using, so check the output volume of your instrument, the cable your using to connect the instrument to your interface and also the position Input gain knob on your UMC22.

What is the instrument you're using? Also what kind of cable are you using to make the connection?

Brett Boustead;149348 wrote:
It seems that even if I install the ASIO drivers when I connect the UMC22 windows automatically downloads Behringer drivers for it.
I've tried updating the drivers by selecting the ASIO folder but it says there are no driver files compatible.

What's worse is I had it working a day ago.

Ive tried everything & Im simply stuck, not sure what to do next - Any help would be greatly appreciated!!


I would try completely uninstalling whatever "driver" Windows tried to automatically install for you (and any drivers you see with the name BEHRINGER, MUSIC GROUP or UMC22), as well as the ASIO4ALL driver from your system, and then perform a fresh reboot of your computer. This time, once it boots up again, before plugging the UMC22 into your computer, install the ASIO4ALL driver using the link provided on our website. After successfully doing that, then plug in the UMC22 to your computer and the it should be recognized and run as expected.

Hope this helps!
Michael Lapke
Highlighted
Contributor - Level 1

Re: Can't get UMC22 to work

I can't get my UMC22 to work on my PC with Windows10, either.  When I first plugged it in, the microphone (dual XLR and 1/4' jack) input would work, but the instrument channel (channel 2) would not work.  So I tried loading ASIO4All, which didn't solve the problem. The I tried loading the Behringer driver, which made it even worse because no channels would work then.  To make matters worse, when I uninstalled the Behringer drivers, it must have taken more than just the Behringer drivers with it when it left. Now the power light won't even come on, on the UMC22.  I tried hooking it up to a different computer with the 32 bit version of Windows 10.  It was a repeat performance of the first time I plugged it into the other computer: the left channel worked, and the right channel would not work.  Interestingly on the first computer that I was using, my UMC204HD works fine.  It's only the UMC22 that doesn't work right.  That tells me that it's a driver issue as the UMC22.  For starters, on my first computer, I need to get back to the point where the power light goes on when the UMC22 is plugged into the USB slot.  Then I need to get both channels working.  I'm using an older Duo Core processor computer, loaded up with Windows 10, but because the UMC204HD works fine, this should be OK hardware for running the UMC22.  Oh, before I forget, on the original computer, now my little UCA202 interface won't show the power light either.  The Behringer driver screwed up my computers USB ablity to see both the UMC22 and the UCA202 interfaces.  Please advise me on how to get these working.  Yes, I have three Behringer interfaces.  I plan on using them in different recording environments. 

Highlighted
Contributor - Level 1

Re: Can't get UMC22 to work

I don't know how old this post is but has anyone figured out the UMC22 yet?

Highlighted
Superhero - Level 3

Re: Can't get UMC22 to work

@Dean0221 

Hello Dean, welcome to the community.

 

What problem do you have with the UMC22? Which OS version are you running? There are solutions for some of the problems that users have reported.