Highlighted
Contributor - Level 1

I can't make UMC22 work properly.

Greetings. I can't make UMC22 work properly.

I got the audio cart two days ago. Installed the ASIO4ALL driver and followed all possible instructions. But my PC wouldn't recognize it as an audio cart. It remains in section "other devices". The "power" light isn't working, but Reaper finds ASIO4ALL drivers.

After all misadventures I found the UNC22 driver in the YouTube video "Behringer UMC22 Driver Setup - Behringer USB Audio Interface", after the installation of that driver, my system have recognized audio card and the power light turned on. Then in ASIO settings I chose "Behringer usb audio" instead of ASIO4ALL v2 and my mic began to work correctly, BUT audio output through the headphones slot works poorly. All sounds are followed by some types of clicks, clacks, noise, interference, etc. If you play music, instrumental part is much louder then vocal. Direct monitor also barely function - it's very quiet and if you want to hear it you'll need to crank up the output at max. (But if you do so you will here interference even with sound turned off)

Tell me, please, how to fix the audio output, and, if the problem caused by driver, then what seems to be the problem with ASIO4ALL?

Windows version 1903, 64 bit. Thank you in advance

skiII Contributor - Level 1 2019-10-20

2019-10-20

I can't make UMC22 work properly.

Greetings. I can't make UMC22 work properly.

I got the audio cart two days ago. Installed the ASIO4ALL driver and followed all possible instructions. But my PC wouldn't recognize it as an audio cart. It remains in section "other devices". The "power" light isn't working, but Reaper finds ASIO4ALL drivers.

After all misadventures I found the UNC22 driver in the YouTube video "Behringer UMC22 Driver Setup - Behringer USB Audio Interface", after the installation of that driver, my system have recognized audio card and the power light turned on. Then in ASIO settings I chose "Behringer usb audio" instead of ASIO4ALL v2 and my mic began to work correctly, BUT audio output through the headphones slot works poorly. All sounds are followed by some types of clicks, clacks, noise, interference, etc. If you play music, instrumental part is much louder then vocal. Direct monitor also barely function - it's very quiet and if you want to hear it you'll need to crank up the output at max. (But if you do so you will here interference even with sound turned off)

Tell me, please, how to fix the audio output, and, if the problem caused by driver, then what seems to be the problem with ASIO4ALL?

Windows version 1903, 64 bit. Thank you in advance

  • 0 Kudos
  • 0 Replies
  • Reply