Highlighted
Contributor - Level 1

UMC22 - Mic Feedback/Issues after Windows 10 Update

So yesterday, I began having issues with my setup after have no issues for months. My microphone all of a sudden sounds like it's outside my house with the winds gusting at 45mph, meanwhile my voice sounds like I'm 50 feet away from the mic. Here's my setup:

 

UMC22

Rode NT-1 mic

Amazon Basics XLR cable

Windows 10 Pro 64-Bit

 

I have tried everything I possibly could: reinstalled ASIO drivers, plugged the UMC22 into different USB ports (they're all USB 3.0 or better), purchased a different brand XLR cable, Used older ASIO drivers, etc. I've also tried to create distance between the interface and my computer/phone/monitor just in case those electronics were causing interference, but nada.

 

At this point it feels like it's an issue with the interface or my mic, neither of which are going to be cheap to repair/replace. Thank you all for your assistance!

ArtrexisLives Contributor - Level 1 05-13-2019

05-13-2019

UMC22 - Mic Feedback/Issues after Windows 10 Update

So yesterday, I began having issues with my setup after have no issues for months. My microphone all of a sudden sounds like it's outside my house with the winds gusting at 45mph, meanwhile my voice sounds like I'm 50 feet away from the mic. Here's my setup:

 

UMC22

Rode NT-1 mic

Amazon Basics XLR cable

Windows 10 Pro 64-Bit

 

I have tried everything I possibly could: reinstalled ASIO drivers, plugged the UMC22 into different USB ports (they're all USB 3.0 or better), purchased a different brand XLR cable, Used older ASIO drivers, etc. I've also tried to create distance between the interface and my computer/phone/monitor just in case those electronics were causing interference, but nada.

 

At this point it feels like it's an issue with the interface or my mic, neither of which are going to be cheap to repair/replace. Thank you all for your assistance!

  • 0 Kudos
  • 2 Replies
  • Reply
Valued Contributor - Level 1

Re: UMC22 - Mic Feedback/Issues after Windows 10 Update

Hi Sam ( @ArtrexisLives ),

 

Welcome to the community.  This is going to be a divide and conquer session.  First thing you need to try is a new XLR cable. Then you need to test your mic on another interface and also test your interface with another mic.  If, in the end, the problem stays with the interface, we'll then need to determine if it's a hardware issue or a software issue.  At that point I'd recommend trying to test the interface on a Mac to remove the Windows OS from the equation. 

 

EDIT: Just thought of something else. Check to make sure "Enhancements" didn't get turned on somehow. That can cause similar behavior. 

 

Hope this helps, 

Ken

 

If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver
Contributor - Level 1

Re: UMC22 - Mic Feedback/Issues after Windows 10 Update

Just to provide an update on the status of my mic issues, I went and submitted it to Rode to look it over and it turns out it was a defective capacitor. After getting it back, the mic worked just fine!

Thank you for your assistance earlier! And let this remind people to register their mics at Rode to get that extended warranty!