Highlighted
Contributor - Level 2

UMC404HD only plays at 44100Hz in Windows

I've been having a really hard time with my UMC404HD.
It used to work fine. Then, slowly, over time, I'd have to un-plug and re-plug it to get it to work. Then, it basically never worked, even for simple audio output.

I noticed in the Windows playback->Speaker Properties->Advanced settings, I can only get any audio output if I have a 44100Hz option (16 or 24bit) selected. After discussing this problem with tech support, they decided to send me a warranty replacement. I was hopeful that it was a hardware problem, but it is not. The new device does exactly the same thing.

I've tried:

  • Reboooting
  • Re-installing the latest drivers like 5x
  • Re-installing my PC audio drivers (Realtek HD) like 3x
  • Unplugging, re-plugging the device
  • Changing exclusive mode


I'm out of ideas. Is anybody else able to actually use this thing with the latest version of Windows 10?

A few other things that might be of concern:
I have a SteamLink, which installs some separate weird audio driver.
I have both Presonus Studio One and Reaper installed. I haven't even gotten so far as to try to use them lately... I just want Windows sound output to be reliable!!!


Thanks!
BrianSaghy Contributor - Level 2 2017-12-09

2017-12-09

UMC404HD only plays at 44100Hz in Windows

I've been having a really hard time with my UMC404HD.
It used to work fine. Then, slowly, over time, I'd have to un-plug and re-plug it to get it to work. Then, it basically never worked, even for simple audio output.

I noticed in the Windows playback->Speaker Properties->Advanced settings, I can only get any audio output if I have a 44100Hz option (16 or 24bit) selected. After discussing this problem with tech support, they decided to send me a warranty replacement. I was hopeful that it was a hardware problem, but it is not. The new device does exactly the same thing.

I've tried:


  • Reboooting
  • Re-installing the latest drivers like 5x
  • Re-installing my PC audio drivers (Realtek HD) like 3x
  • Unplugging, re-plugging the device
  • Changing exclusive mode


I'm out of ideas. Is anybody else able to actually use this thing with the latest version of Windows 10?

A few other things that might be of concern:
I have a SteamLink, which installs some separate weird audio driver.
I have both Presonus Studio One and Reaper installed. I haven't even gotten so far as to try to use them lately... I just want Windows sound output to be reliable!!!


Thanks!

  • 0 Kudos
  • 8 Replies
  • Reply
Valued Contributor - Level 1

Re: UMC404HD only plays at 44100Hz in Windows

Brian Saghy;136718 wrote:
I've been having a really hard time with my UMC404HD.
It used to work fine. Then, slowly, over time, I'd have to un-plug and re-plug it to get it to work. Then, it basically never worked, even for simple audio output.

I noticed in the Windows playback->Speaker Properties->Advanced settings, I can only get any audio output if I have a 44100Hz option (16 or 24bit) selected. After discussing this problem with tech support, they decided to send me a warranty replacement. I was hopeful that it was a hardware problem, but it is not. The new device does exactly the same thing.

I've tried:

  • Reboooting
  • Re-installing the latest drivers like 5x
  • Re-installing my PC audio drivers (Realtek HD) like 3x
  • Unplugging, re-plugging the device
  • Changing exclusive mode


I'm out of ideas. Is anybody else able to actually use this thing with the latest version of Windows 10?

A few other things that might be of concern:
I have a SteamLink, which installs some separate weird audio driver.
I have both Presonus Studio One and Reaper installed. I haven't even gotten so far as to try to use them lately... I just want Windows sound output to be reliable!!!


Thanks!

Hi Brian,

Welcome to the forums. I'm running a nearly identical setup as you without issue so we should be able to solve this one together. I'm running Windows 10 Pro Version 1709, OS Build 16299.64. My first question is "What are you using to test playback? (i.e. the Test button on the Advanced tab?)"

Start by bringing up the UMC Audio Control Panel and selecting the Status tab. Make note of the "Current Sample Rate". Does it match what you have it set to on the Speaker Properties->Advanced tab? Try changing it something else on the Advanced Tab and then watch the Current Sample Rate when you press the Test button. Did it change to match the sample rate you selected on the Advanced Tab?

Based on the above test we'll decide where to go next.

EDIT: BTW, What version of the UMC driver are you running? You should be running 3.29.

Ken
If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver
Contributor - Level 2

Re: UMC404HD only plays at 44100Hz in Windows

Hey, thanks for your reply!

I'm running Windows 10 Home Version 1709 Build 16299.125

AMD Ryzen 7 1700 machine with Realtek ALC892 onboard audio chip.

To test playback, yes, I'm using the audio settings advanced tab. I'll select a "Default Format" and hit the "Test" button. For any 44100Hz option, I get playback. Indeed, when I change the sample rate in Windows, it doesn't change in the UMC Control Panel. Any idea what could cause this?

FWIW, Spotify also won't output any sound unless I select 44100Hz in the Windows settings.

And yes, I'm running 3.29.0

Thanks!
Valued Contributor - Level 1

Re: UMC404HD only plays at 44100Hz in Windows

Brian Saghy;137221 wrote:
Hey, thanks for your reply!

I'm running Windows 10 Home Version 1709 Build 16299.125

AMD Ryzen 7 1700 machine with Realtek ALC892 onboard audio chip.

To test playback, yes, I'm using the audio settings advanced tab. I'll select a "Default Format" and hit the "Test" button. For any 44100Hz option, I get playback. Indeed, when I change the sample rate in Windows, it doesn't change in the UMC Control Panel. Any idea what could cause this?

FWIW, Spotify also won't output any sound unless I select 44100Hz in the Windows settings.

And yes, I'm running 3.29.0

Thanks!

Hi Brian,

Based on the behavior you describe I can easily see why tech support would think the unit was defective. If the sampling rate on the driver control panel isn't updating when a program changes the sampling rate that's a big problem.

I think your best course of action is to do a thorough cleaning of the Behringer driver(s) and start again. With the 4040HD still plugged in, go into device manager and select uninstall device. When prompted select the option to delete the driver software associated with the device. I don't have my Windows laptop with me today so I can't check for sure but you may also want to run the uninstall option under Windows setup to further clear the driver software.

Once your done, unplug the 404HD and reboot your PC. Run the driver installation without the 404HD plugged in and then finally plug the 404HD back in.


Let us know how that goes.
Ken
If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver
Contributor - Level 2

Re: UMC404HD only plays at 44100Hz in Windows

I've done exactly as you said - uninstalled through the device manager, also uninstalled the UMC application. Rebooted. I even ran CCleaner to try to get rid of anything else that may have been left. Rebooted.

Installed the UMC 3.29.0 drivers again from scratch. Plugged in the UMC404HD, and same results - it just won't play anything other than 44100hz and the UMC app doesn't show the sample rate change. This is so frustrating
Valued Contributor - Level 1

Re: UMC404HD only plays at 44100Hz in Windows

OK, It's time to deinstall that "weird" SteamLink audio driver.

Ken
If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver
Contributor - Level 1

Try just disabling the other playback devices

I had this same issue and it seems I got it working by disabling other playback devices. I confirmed it after disabling others by switching the Behringer setting back to 48k, then testing it with the Test button on the Advanced tab. I hit Apply then Done. Everything -- including Spotify -- played back fine.

Good luck and I hope for both of us it continues to work!
Contributor - Level 2

Re: UMC404HD only plays at 44100Hz in Windows

I may have *finally* gotten this to work! I think Reaper was to blame, somehow.
I tried:

  • Reinstalling the newest UMC 4.38 drivers
  • Disabling/uninstalling steamlink audio drivers
  • Disabling/uninstalling motherboard's Realtek Audio drivers
  • Disabling the Realtek device in the BIOS
  • Re-installing the UMC drivers numerous times
  • Killing all kinds of tasks that might *possibly* be messing with the audio


Nothing helped!
Then I went into Reaper to mess around with settings. ASIO kinda messed with things, but then after selecting between ASIO, WASPI, then Direct Sound, and back... everything started working as expected...

What?!

Now I can change between the Default Format in the Windows Device properties - and they all work.

So... weird. I'm guessing maybe some previous run of Reaper (months ago?) somehow left the audio drivers or configuration in some screwed up state that no amount of uninstalling/reinstalling would help. Fingers crossed it lasts through the next reboot!
Contributor - Level 1

Same problems here

Hello all

I received my UMC404HD two days ago and have been battling with the same problems since then. In Reaper I like to record at 48k/256 and sometimes watch tutorials on YouTube.

I tried the steps above and am still unable to play Spotify or YT when reaper is open in 48k mode. Windows/Chrome seems to force 192k and then there's no playback.

Rather irritating me as my 2i2 didn't have any of these problems, albeit 2 less inputs.

Any ideas?