Contributor - Level 2

Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

I noticed yesterday that the UM2 Windows drivers made my Behringer are gone.

Knowing that the UCG102 shares the same driver, I went to it's download page, and it's also gone:

http://www.behringer.com/EN/Products/UM2.aspx
http://www.behringer.com/EN/Products/UCG102.aspx

What's going on here? Did I catch the website during an update gone wrong? Or is something else going on?

Ultimately ... are they coming back?

Any help would be appreciated,
Seth
SethCall Contributor - Level 2 2015-05-22

2015-05-22

Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

I noticed yesterday that the UM2 Windows drivers made my Behringer are gone.

Knowing that the UCG102 shares the same driver, I went to it's download page, and it's also gone:

http://www.behringer.com/EN/Products/UM2.aspx
http://www.behringer.com/EN/Products/UCG102.aspx

What's going on here? Did I catch the website during an update gone wrong? Or is something else going on?

Ultimately ... are they coming back?

Any help would be appreciated,
Seth

  • 0 Kudos
  • 13 Replies
  • Reply
Highlighted
Triber Moderator

Re: Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

Hi Seth,

Welcome to the forums! I'm not sure why you can't see the drivers but I just checked and they are indeed there. (both links) After clicking either of the links you provided just click on "download" and then scroll down and you should see it.
Michael Lapke
Highlighted
Contributor - Level 2

Re: Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

Hi Michael,

Thanks for the response.

If I click either link, and scroll all the way to the bottom, the only driver available in the section called 'Drivers' is ASIO4ALL (definitely not the driver I'm looking for).

This is quite unexpected; until very recently, someone could also find both the Behringer 32bit and 64bit Windows drivers in that section as well.

Are you seeing more than just the ASIO4ALL driver? Or has something indeed gone off the rails here?

Thanks!

Seth
Highlighted
Contributor - Level 1

Re: Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

Hey Michael -

I have the same question. The only driver listed now is ASIO4ALL, which is not good. Where did the Windows ASIO driver written by Behringer specifically for the UM2 go? It's not there, and it used to be. The Behringer driver was/is good. ASIO4ALL not good.
Highlighted
Contributor - Level 2

Re: Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

Hi Michael,

I hate to be a bother but do you have any insight into this problem?

Thanks,
Seth
Highlighted
Triber Moderator

Re: Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

Seth,

You will notice underneath where the ASIO4ALL driver is on those webpages it says:

ASIO4ALL USB Audio Driver
- Combined 32/64-bit 3rd party driver for Windows
- Supports Windows XP to 7 (32/64-bit)
- For OS X no drivers required

This is indeed the driver you are are looking for. Have you tried installing it yet?
Michael Lapke
Highlighted
Contributor - Level 1

Re: Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

Hi Michael,

I am also looking for the Windows device driver for the UM2. The interface is advertised as having ultra-low latency, this can only be achieved by having an ASIO device driver specifically for the device, asio4all does not achieve this.

Seth and David have both mentioned that there is a windows driver for the UM2, can be made available?

Thanks,
Matt
Highlighted
Triber Moderator

Re: Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

Dear All,

I was just informed that a recent test of the ASIO4ALL driver latency with Win7/8/8.1 PCs that the driver performance should work properly with this setups and your UCG102 and UM2 products. We suggest you download them from the Behringer website if you haven't done so already to try them and see for yourself.

However, if you have done that already and are convinced that the other drivers will work better for you then you are welcome to contact our CARE Department and request the drivers directly via email. You can contact them via care@music-group.com. Hope this helps!
Michael Lapke
Highlighted
Contributor - Level 2

Re: Where did the Behringer ASIO drivers for the UCG102 and UM2 go?

Hi Michael,

The Behringer-written driver is much better than ASIO4ALL in essentially almost any aspect you judge against. This comes from extensive personal testing and also dealing with many users of the UM2 and other audio products.

If there is any chance that the driver can show back up, I'm certain all UM2 users would appreciate it.

EDIT: I did not mean to sound unappreciative. I'm glad there is still a way to get the driver at all. I'm just very surprised it's been pulled down.
Highlighted
Contributor - Level 1

Hey Michael, sorry to pile on but.....

Seth Call;55155 wrote:
Hi Michael,

The Behringer-written driver is much better than ASIO4ALL in essentially almost any aspect you judge against. This comes from extensive personal testing and also dealing with many users of the UM2 and other audio products.

If there is any chance that the driver can show back up, I'm certain all UM2 users would appreciate it.

EDIT: I did not mean to sound unappreciative. I'm glad there is still a way to get the driver at all. I'm just very surprised it's been pulled down.


....and now let's introduce Win10 into the mix. My machine crashed, had to take to the shop and got it back yesterday loaded with Win10. Downloaded the ASIO4ALL driver from the site, as an administrator, and it's definitely there in my file explorer, but my recording program simply doesn't acknowledge it and there certainly is no ASIO4ALL system tray that shows up anywhere. I don't do anything special with my recording, just use Audacity to check my progress on guitar and vocals, and my UM2 and the old driver worked fine on win8 but this--like it's not even there. I don't really care what driver it is, old one or ASIO4ALL, just as long as it works. What to do?