Contributor - Level 2

X 18 driver doesn't work but the M 18 does

I have been trying to record one band with my X18 and have had no luck.  The M 18 driver, which I used for my other band using my Midas mixer works just fine.  I have used driver versions 2.23, 4.11 with no luck.  Is there a version that works that I am unaware of?  The 2.23 version does allow me to record but there is some latency issues with that driver.  I was assuming that the current driver 4.38 would work with both the X18 and the M18 but I guess I'm wrong.  Can anyone identify the issue with the X18 driver problem?

JeffGallagher Contributor - Level 2 04-12-2019

04-12-2019

X 18 driver doesn't work but the M 18 does

I have been trying to record one band with my X18 and have had no luck.  The M 18 driver, which I used for my other band using my Midas mixer works just fine.  I have used driver versions 2.23, 4.11 with no luck.  Is there a version that works that I am unaware of?  The 2.23 version does allow me to record but there is some latency issues with that driver.  I was assuming that the current driver 4.38 would work with both the X18 and the M18 but I guess I'm wrong.  Can anyone identify the issue with the X18 driver problem?

  • 0 Kudos
  • 5 Replies
  • Reply

Accepted Solutions
Highlighted
Volunteer Moderator

Re: X 18 driver doesn't work but the M 18 does


@JeffGallagher wrote:

The first thing that I would have to question is what is the most recent version of the X18 driver?  At one time I did have both drivers loaded and recognized by Reaper.  My new computer doesn't 'see' the X18 but does 'see' the M18 driver.  Since the ASIO device doesn't 'see' or recognize my driver, I cannot populate the first and last channel strips in Reaper.  The X Air Edit shows signal but that signal doesn't show up in Reaper.  I can use the same software (X Air Edit) for my Midas, go into Reaper to set up the ASIO device and have no problems being recognized.  I have used the same USB port and cable for the Behringer and the Midas.


Then I would suspect that the X-Air driver (which is required for the X18 console) is not installed. Check the list of installed apps in Windows. At the bottom of the list should be the X-Air driver (don't remember the exact name, since I'm at work).

 

Paul Vannatto, Volunteer Forum Administrator and Moderator
Volunteer Moderator

Re: X 18 driver doesn't work but the M 18 does

Hi Jeff (@JeffGallagher), 

 

The M-Air driver is different than the X-Air driver. You need to install the X-Air driver for those consoles to work properly.

Paul Vannatto, Volunteer Forum Administrator and Moderator
Contributor - Level 2

Re: X 18 driver doesn't work but the M 18 does

Paul-Thanks for your reply.  I did download the version 4.38 which you provided.  This is the driver used for the Midas mixer too; but for some reason this driver does not allow the software (Reaper) to recognize the X18.  I have tried 3 different computers and get the same result.  I know it is not a Windows issue since the M18 mixer and driver work fine.  With the X18 I cannot populate the first and last channels when using the ASIO driver. I have deleted Reper and reloaded it, tried 3 different drivers and re-loaded the firmware and none of this will allow me to load the ASIO driver.

Volunteer Moderator

Re: X 18 driver doesn't work but the M 18 does

Hey Jeff (@JeffGallagher), then you should have both the M-Air and X-Air drivers installed, correct? When you connect the X18 to the computer (with the USB cable), can you see it in the X-Air Control panel? In Reaper, are you choosing the X-Air driver instead of the M-Air driver? (Yes they are different). I have both installed on my laptop (at home) since I use both the XR18 and MR18 and have to make sure that I choose the correct driver for the appropriate console connected.

 

 

 

Paul Vannatto, Volunteer Forum Administrator and Moderator
Contributor - Level 2

Re: X 18 driver doesn't work but the M 18 does

The first thing that I would have to question is what is the most recent version of the X18 driver?  At one time I did have both drivers loaded and recognized by Reaper.  My new computer doesn't 'see' the X18 but does 'see' the M18 driver.  Since the ASIO device doesn't 'see' or recognize my driver, I cannot populate the first and last channel strips in Reaper.  The X Air Edit shows signal but that signal doesn't show up in Reaper.  I can use the same software (X Air Edit) for my Midas, go into Reaper to set up the ASIO device and have no problems being recognized.  I have used the same USB port and cable for the Behringer and the Midas.

Highlighted
Volunteer Moderator

Re: X 18 driver doesn't work but the M 18 does


@JeffGallagher wrote:

The first thing that I would have to question is what is the most recent version of the X18 driver?  At one time I did have both drivers loaded and recognized by Reaper.  My new computer doesn't 'see' the X18 but does 'see' the M18 driver.  Since the ASIO device doesn't 'see' or recognize my driver, I cannot populate the first and last channel strips in Reaper.  The X Air Edit shows signal but that signal doesn't show up in Reaper.  I can use the same software (X Air Edit) for my Midas, go into Reaper to set up the ASIO device and have no problems being recognized.  I have used the same USB port and cable for the Behringer and the Midas.


Then I would suspect that the X-Air driver (which is required for the X18 console) is not installed. Check the list of installed apps in Windows. At the bottom of the list should be the X-Air driver (don't remember the exact name, since I'm at work).

 

Paul Vannatto, Volunteer Forum Administrator and Moderator