Highlighted
Contributor - Level 2

X-Air Edit app keeps defaulting to Static IP in LAN settings

I'm using an XR18. I've installed the latest version of the firmware and the X-Air Edit app for PC. My software will frequently fail to connect to my XR18. The XR18 is connected to a wifi router directly via Ethernet and the PC connects to the same router via wifi.

This is an intermittent problem. When it happens, I check the LAN setting in the app and it's always on "Static." I can occasionally change it back to DHCP, click "apply" and then my mixer will show up and I'm able to connect to it. But, this only works occasionally. Often, it just won't connect at all, even after several restarts of the app and Windows.

This all seems very random and of course, the intermittent problem shows up when I most need things to function properly.

Any ideas?
ChrisHarris Contributor - Level 2 2018-03-08

2018-03-08

X-Air Edit app keeps defaulting to Static IP in LAN settings

I'm using an XR18. I've installed the latest version of the firmware and the X-Air Edit app for PC. My software will frequently fail to connect to my XR18. The XR18 is connected to a wifi router directly via Ethernet and the PC connects to the same router via wifi.

This is an intermittent problem. When it happens, I check the LAN setting in the app and it's always on "Static." I can occasionally change it back to DHCP, click "apply" and then my mixer will show up and I'm able to connect to it. But, this only works occasionally. Often, it just won't connect at all, even after several restarts of the app and Windows.

This all seems very random and of course, the intermittent problem shows up when I most need things to function properly.

Any ideas?

  • 0 Kudos
  • 3 Replies
  • Reply
Highlighted
Superhero - Level 3

Re: X-Air Edit app keeps defaulting to Static IP in LAN settings

Chris, the network settings in X-Air Edit are only valid when it is connected to the mixer. When not connected, it defaults to STATIC. Changing the settings would have no effect unless it was connected to the mixer.

It is possible that your problem happens because the XR was not able to get an IP address issued by your router. This could be because the router was not ready when the XR was started. Try turning on your router first and waiting until it has finished its start-up before powering-up the XR.

If the problem happens again, try moving the network switch on the XR to ACCESS POINT for a few seconds and then back to ETHERNET. This will cause the XR to re-request an IP address from the router.

If none of this helps, you could reset the XR's network settings by briefly pressing (less than two seconds) the reset button through the hole near the network switch. You would then need to connect via the ACCESS POINT and re-enter your network settings. The new settings would take effect when you change the network switch back to ETHERNET. If you hold the reset button in for too long, the XR will be initialized and you would need to reload your scene or snapshot.
Highlighted
Contributor - Level 2

Re: X-Air Edit app keeps defaulting to Static IP in LAN settings

I have my XR18 set to a static IP.
I have no connection issues on the 3 different
networks I use it with. Of course all these networks have the same
ip settings Smiley Happy
It solves the problem of waiting for the router to dish out IP address.
And you know it's address.
Highlighted
Contributor - Level 3

Re: X-Air Edit app keeps defaulting to Static IP in LAN settings

+1. Same here. I always use Static IP addresses for all my devices on my Show network WiFi router.