SteveKatsikas Contributor - Level 2 2019-06-02

2019-06-02

X32 and sample rate issue in Windows 10

Greetings!  I am at my wits end trying to solve an issue.  I am running Windows 10 with a pretty zippy system (includes 16 GB RAM and i7 quad processor).  The Main drive is a 500GB SSD.  The issue I am having is that is seems as though windows is locked to 48KHZ.  As longas the X32 is in 48 Khz, everything is fine.  I can play wav files, youtube, and do recording and mixing via Cakewalk (my DAW).  The challenge is with a few older cakewalk projects that were recorded at 44.1.  If I switch the mixer to 44.1, nothing will play (and it gives me errors).  However, within cakewalk, I CAN set it to 44.1 within the software AND within the X32.  My project will play fine.  However, when I render it down, it has clicks and pops in it.  I've done the typical things like remove all effect, problem persists.  I have upgraded all drivers to the most recent (including 6.13 for the X32's X-UF drivers) and updates all firmware (inlcuding now running 3.08 on the x32).  I've also played with the latency, to no avail.  If I were to guess at the problem, it seems like a clock issue, with the computer NOT following the X32 when the sample rate is changed to 44.1.  The weirdness of this sort of working within the DAW is a real puzzle (but maybe a clue to a smart person out there).  A workaround is for me to do everything in 48Khz, but I really have a number of older projects in 44.1 that need to be finished too.  I look forward to your suggestions.

  • 0 Kudos
  • 12 Replies
  • Reply
Contributor - Level 3

Re: X32 and sample rate issue in Windows 10


@SteveKatsikas wrote:

Tried it and it says "The best drivers for your computer are already installed".  


Yes that is the whole point. the drivers that Windows installs and thinks are best aren't necessarily for audio interfaces. What drivers does Windows show as installed? Hence the advice to get hold of the 2006 legacy ones thst do work OK where the modern Windows ones don't.

Contributor - Level 3

Re: X32 and sample rate issue in Windows 10

ScreenHunter_79 Jun. 09 17.36.jpg

Highlighted
Contributor - Level 2

Re: X32 and sample rate issue in Windows 10

Gotcha,

 

Went ahead and manually installed the legacy drivers, but the issue persists all the same.  Thanks for the suggestion.