Cannot factory reset FX150 - latest firmware applied! HELP!

Contributor - Level 1
We've been using the FX150s for a couple of years as personal monitors in our band and they are great. They've survived a lot of abuse and I recently discovered the firmware update was available for them. We have 6 of these by the way!

One of them, will not allow me to factory reset it - no matter how many times I've tried, I simply cannot access the input trim on channel 1 or 2.

Another bizarre issue is that the vocal tone button is pale green when nothing is connected and when I press it down, it turns pale red. Not flashing, steady. Only unit to do this! It allowed the firmware to be updated like the other units, but they allow the input trim to be altered (as per the instructions in the manual).

Not sure if this is a fault with the unit, something we can easily overcome or if there's a manual firmware fix for this out there? Anyone seen this before?

Any suggestions would be gratefully received.

Many thanks!

Re: Cannot factory reset FX150 - latest firmware applied! HELP!

Triber Moderator
Hey Lewis,
That's awesome to hear you guys have a little family of half a dozen FX150's Smiley Happy Sorry that there's a bad apple in there though...
So to perform a factory reset on the FX150, you hold the three "LOW" buttons (one on each of the three channels) while powering on the speaker, and continue holding them while it boots up. This is what you're attempting, right? Have you tried hooking the troublemaker up to VoiceSupport via USB? Our free app can be used to update the firmware in your speakers (something worth doing to the whole lot) so I'd be interested to see if VoiceSupport recognizes the one that's acting wonky. If VoiceSupport doesn't see your speaker, then something might really be up with the software and you may have to get in contact with our support team.
Spencer Larsen - Testing Engineer @ TC Helicon, MUSIC Tribe. Our Support Team is always available for more urgent assistance.