Vocal

If singing is your thing then this page is for you! Join other vocalists and talk about singing techniques, tips, favorite artists, gear, experiences and more.

Highlighted

Second Time Using VL3E, just has a blank, blue screen at startup

Contributor - Level 2
So I just got a brand new VL3E. I turned it on, and I started going through the presets. It worked fine. I then turned it off to move it to my room...then turned it back on, and all I see is a blank, blue screen.

I have no idea what to do now to make it work again. Like I said, it’s brand new, and I only used it once.

Any suggestions on what I should do?

Thank you,

~Michael
Tags (1)
3 REPLIES 3

Blank...

Contributor - Level 2
Hi Michael,

I'd first try to make a factory reset. There is a hidden switch inside the 1/8 headphone jack... Check out in your manual on how to use it.. Use a straightened paper clip and be gentle... you should get a light click if all is good...

It is very well explained in the user manual...

Other than that, if it fails, this is a warranty issue. Contact support.

And...

Contributor - Level 2
ALWAYS make sure to turn the power of by the switch and NOT just unplug it from the wall.. this should be turned down exactly as a PC would be.. it IS, in fact, a powerful PC under Linux...

Re: Second Time Using VL3E, just has a blank, blue screen at startup

Contributor - Level 2
Thanks for the tip Dennis!

I tried to do the manual reset with the paper clip, but I'm still getting a blue screen at the start up.

I guess I'll try contacting TC Helicon support to see if they can help.

Thanks!

~Michael
Conversation Stats
  • 3
  • Replies
  • 165
  • Views
  • 0
  • Kudos Given
  • 2
  • Contributors