Vocal

If singing is your thing then this page is for you! Join other vocalists and talk about singing techniques, tips, favorite artists, gear, experiences and more.

Highlighted

USB issues. Play Acoustic

Contributor - Level 2
USB connection to my laptop (Windows 10) and my new-ish Play Acoustic only works for firmware updates and nothing else. Kicker is, it did work yesterday when I sent YouTube tunes to my Play and tried the Voice Cancel feature (it all worked fine - but not anymore!

Input is set to USB, Input and Output USB levels are maxed, tried a new USB cable etc. Even tried a factory reset. No go. Nothing! The laptop is just not picking up the Play's USB connection. (USB from laptop straight to monitors works fine)

What am I missing? What's going on?
Tags (1)
2 REPLIES 2

Re: USB issues. Play Acoustic

Contributor - Level 2
Hi Daniel,
It may work better for You tube videos to run the headphone out of the PC to aux in of the Play Acoustic via 3.5mm stereo cable.

There is somehow a setting that I can’t remember how to access. It tells the Play Acoustic what the usb is used for - to update or transfers sound. Can’t seem to find it in the Play Acoustic. So it must be a setting on the PC. If I can find it, I will let you know.

Re: USB issues. Play Acoustic

Triber Moderator
Hey Daniel,
My bet is that Windows has disabled the device and you need to make it visible. Check out this thread for details on how to do that, good luck!
Spencer Larsen - Testing Engineer @ TC Helicon, MUSIC Tribe. Our Support Team is always available for more urgent assistance.
Conversation Stats
  • 2
  • Replies
  • 267
  • Views
  • 0
  • Kudos Given
  • 3
  • Contributors